High marketplace volume
Incident Report for NBA Top Shot
Resolved
We've resolved this issues.
Posted Feb 19, 2021 - 21:11 PST
Monitoring
We've identified the cause of this issue and have addressed it.
Posted Feb 19, 2021 - 20:47 PST
Investigating
High marketplace volume is causing some strain in our payment systems
Posted Feb 19, 2021 - 20:34 PST
This incident affected: Marketplace, Pack Purchasing (if any packs are available), Pack Opening, and Gifting.