Marketplace Maintenance
Incident Report for NBA Top Shot
Resolved
Maintenance is over.
Posted Jun 15, 2022 - 13:46 PDT
Update
We are continuing to investigate this issue.
Posted Jun 15, 2022 - 07:52 PDT
Investigating
We're currently undergoing a scheduled maintenance to improve our systems. Packs, Marketplace, and Gifting will be back soon.
Posted Jun 15, 2022 - 07:49 PDT
This incident affected: Marketplace, Pack Purchasing (if any packs are available), Pack Opening, and Gifting.