Investigating issues
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Jun 14, 2021 - 11:45 PDT
Investigating
We are currently investigating this issue.
Posted Jun 14, 2021 - 10:41 PDT
This incident affected: Marketplace, Pack Purchasing (if any packs are available), and Pack Opening.