Quick maintenance to resolve volume issues
Incident Report for NBA Top Shot
Resolved
We are continuing to work on a fix for this issue.
Posted Feb 20, 2021 - 13:27 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 20, 2021 - 13:02 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2021 - 12:59 PST
This incident affected: Website, Marketplace, Pack Purchasing (if any packs are available), Pack Opening, and Gifting.