Marketplace is off
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Feb 24, 2021 - 18:30 PST
Investigating
We're investigating an issue with the marketplace
Posted Feb 24, 2021 - 16:13 PST
This incident affected: Marketplace.