Marketplace is off for pack drop stress test
Incident Report for NBA Top Shot
Resolved
We're back now that the pack drop is over!
Posted Feb 24, 2021 - 14:46 PST
Monitoring
We have turned off the marketplace for our stress test, will update when it's back up!
Posted Feb 24, 2021 - 13:38 PST
This incident affected: Marketplace.