Moment Offers Maintenance
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 17:21 PST
Investigating
Offers on Moments are currently not working correctly. Edition level Offers are not impacted.
Posted Jan 17, 2023 - 16:55 PST
This incident affected: Offers.