Marketplace Maintenance
Incident Report for NBA Top Shot
Resolved
Maintenance has finished.
Posted Oct 06, 2021 - 16:10 PDT
Investigating
We are currently investigating this issue.
Posted Oct 06, 2021 - 06:56 PDT
This incident affected: Marketplace, Pack Purchasing (if any packs are available), Pack Opening, and Gifting.