The Marketplace is temporarily on cooldowns.
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 19:11 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 15, 2021 - 17:41 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 15, 2021 - 16:52 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 15, 2021 - 16:51 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 15, 2021 - 16:16 PDT
Monitoring
The Marketplace will be temporarily down while the Run It Back 2005-06 packs are dropping.
Posted Oct 15, 2021 - 09:32 PDT
This incident affected: Website, Marketplace, Pack Purchasing (if any packs are available), Pack Opening, Gifting, and Signup.