We're currently undergoing scheduled maintenance
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 22:27 PDT
Update
We are continuing to investigate this issue.
Posted Sep 15, 2021 - 22:26 PDT
Investigating
We're currently undergoing a scheduled maintenance to improve our systems. Packs, Marketplace, and Gifting will be back soon.
Posted Sep 15, 2021 - 07:32 PDT
This incident affected: Marketplace, Pack Purchasing (if any packs are available), Pack Opening, and Gifting.