The Marketplace is temporarily on cooldowns while the Run It Back 2005-06 packs are on-going.
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 12:56 PDT
Monitoring
The Marketplace is temporarily on cooldowns while the Run It Back 2005-06 packs are on-going.
Posted Oct 14, 2021 - 10:07 PDT
This incident affected: Marketplace and Gifting.