Marketplace temporarily closed while Premium Pack (Series 2, Drop 3) is dropping.
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Jun 07, 2021 - 16:43 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 07, 2021 - 16:43 PDT
Update
Marketplace cooldowns are currently active.
Posted Jun 07, 2021 - 15:33 PDT
Identified
The Marketplace will be back up after the Premium Pack drop portion is complete.
Posted Jun 07, 2021 - 14:58 PDT
This incident affected: Marketplace and Gifting.