We’ve temporarily disabled signups.
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 17:13 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2021 - 16:42 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2021 - 16:41 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2021 - 16:20 PDT
Identified
We’ll be back soon after the Base Set Stress Test!
Posted Apr 26, 2021 - 13:24 PDT
This incident affected: Marketplace and Signup.