Marketplace will not be available during the Premium Pack drop
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 12:00 PST
Monitoring
This is scheduled and we'll be back after the drop.
Posted Feb 26, 2021 - 08:33 PST
This incident affected: Marketplace and Gifting.