Reports of delays in marketplace purchases
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 11:18 PST
Monitoring
We are monitoring this issue.
Posted Feb 19, 2021 - 22:46 PST
Investigating
We are currently investigating this issue.
Posted Feb 19, 2021 - 22:06 PST
This incident affected: Marketplace.