Marketplace is disabled for the Premium Pack drop @2:00 PM PDT.
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 16:18 PDT
Identified
Visit the packs page
Posted Apr 22, 2021 - 13:30 PDT
This incident affected: Marketplace, Gifting, and Signup.