The Marketplace will be temporarily off during the 'And Then There Were Four' Pack Drop
Incident Report for NBA Top Shot
Resolved
This incident has been resolved.
Posted Jul 14, 2021 - 15:24 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 14, 2021 - 14:59 PDT
Monitoring
We will be bringing the Marketplace back up after the pack drop.
Posted Jul 14, 2021 - 09:56 PDT
This incident affected: Marketplace and Gifting.